Firebird + php 7: Bug im connect

Forum für Fragen rund um Firebird-Software von Drittanbietern.

Moderator: martin.koeditz

bfuerchau
Beiträge: 92
Registriert: Mo 7. Mai 2018, 18:09

Sa 3. Aug 2019, 14:48

"please read the Compatibility"
Könnte darauf hindeuten, dass du in der Firebird.config die "legacy"-anmeldung zulassen musst, da der Treiber noch das 2.5er-Protokoll nutzt.
Hamburgo
Beiträge: 14
Registriert: Di 28. Mai 2019, 17:28

Mo 5. Aug 2019, 16:30

Hallo Befuerchau,

danke für den Tipp, aber das hat leider nicht geklappt oder ich habe etwas falsch gemacht.

Ich habe das nach dieser Anleitung gemacht:
https://firebirdsql.org/file/documentat ... yauth.html

Die Conf habe ich mal als 7z-Datei dran gehängt.

Die selbe Meldung erscheint aber noch immer.

Mit IbExpert kann ich mich problemlos anmelden, auch schon vor der Änderung auf "Legacy".

Auch ein gback funktioniert mit V2.5-Syntax.

Gruss
Bernd
Dateianhänge
firebird.7z
(10.4 KiB) 9-mal heruntergeladen
bfuerchau
Beiträge: 92
Registriert: Mo 7. Mai 2018, 18:09

Di 6. Aug 2019, 11:32

Dann musst du leider auf die Antwort des Herstellers warten.
Benutzeravatar
martin.koeditz
Beiträge: 101
Registriert: Sa 31. Mär 2018, 14:35

Di 6. Aug 2019, 15:21

Hallo Bernd,

das Problem liegt am SRP-Parameter. Einfach entfernen und erneut probieren. Dann sollte es gehen.

Code: Alles auswählen

# Per-database configurable.
#
#AuthServer = Srp
AuthServer = Legacy_Auth, WinSspi
Gruß
Martin
Martin Köditz
it & synergy GmbH
Hamburgo
Beiträge: 14
Registriert: Di 28. Mai 2019, 17:28

Di 6. Aug 2019, 17:18

Hallo Martin,

danke für den Tipp. Es hat geholfen. ;))

Allerdings führt dann die offizielle Beschreibung, nach der ich meine Anpassungen gemacht habe, unter:
https://firebirdsql.org/file/documentat ... yauth.html
in die Irre, zumindest was PHP angeht.

Der entscheidende Unterschied ist nämlich, das in der Beschreibung "Srp" an der 2. Stelle eingetragen bleibt und in Deinem Vorschlag gar nicht vorhanden ist und deshalb wohl funktioniert.

Danke und Gruß
Bernd
Antworten