gbak Error

Forum für Fragen zu Firebirdeigenen Dienstprogrammen wie isql, gbak, nbackup, gfix, etc.

Moderator: martin.koeditz

Antworten
haederli
Beiträge: 8
Registriert: Mi 10. Okt 2018, 13:20

Di 27. Nov 2018, 15:46

Beim Sichern auf einen Windows Server 2016, erhalte ich folgende Fehlermeldung.

"C:\Program Files (x86)\Firebird 3.0\gbak.exe" -b "C:\Program Files (x86)\Vertec\DB\vertec.fdb"
"C:\Program Files (x86)\Vertec\DB\Backup\vertec.fbk" -user SYSDBA -password DBPASSWORT

gbak: EROOR:I/O error during "CreateFile (open)" operation from file "C:\Program Files (x86)\Vertec\DB\vertec.fdb"
gbak: ERROR Error While trying to open file
gbak: ERROR Der Prozess kann nicht auf die Datei zugreifen, da sie von einem anderen Prozess verwendet wird.
gbak:Exiting before completion due to errors


Wir verwenden gbak.exe mit diesen Optionen auf mehrere Server/Rechner, ohne Probleme.
Kann sein, da Server 2016 probleme macht.

den Dienst wollen wir nicht stopen !


danke
bfuerchau
Beiträge: 38
Registriert: Mo 7. Mai 2018, 18:09

Di 27. Nov 2018, 23:08

Warum du den Fehler auf anderen Systemen nicht hast würde mich eher interessieren.
I.d.R. sind die Verzeichnisse "Programme" und "Programme (x86)", ich glaube seit Windows 7 schon, schreibgeschützt und können nur von Installerpaketen (Trusted Installer) oder Admin mit expliziter Bestätigung (UAC) geschrieben und verändert werden.
Schau dir mal die Berechtigungen der Verzeichnisse an.
Eigentlich gibt es dafür das Verzeichnis ProgramData oder eben Dokumente und sonstige individuelle Pfade.
Der Server 2016 ist da wohl noch restriktiver.
Es ist auch unüblich, das Programmverzeichnis für Daten zu verwenden.
Dass du die Datenbank überhaupt bearbeiten kannst, liegt wohl an der Berechtigung des Firebird-Dienstes.
Vielleicht hilft die Option "-se[rvice]", da dann der Backup vom Dienst und mit dessen Berechtigung durchgeführt wird.

Besser wäre allerding sowohl für DB als auch Backup freie Anwendungspfade zu verwenden.
haederli
Beiträge: 8
Registriert: Mi 10. Okt 2018, 13:20

Mi 28. Nov 2018, 08:20

danke für den Hinweis, das die DB in ein eigenes Verzeichnis gehört, aber leider sind das Installationen, die der User selber durch führt!

Das Problem ist aber gelöst, das SYSDBA Passwort war falsch !
Antworten